Exchange 2010 RTM schema prep fails with Exchange 2007 SP3 installed


When you run the prepare schema command (/PS) using the SETUP CLI for Exchange 2010 it fails with the following error:
Setup encountered a problem while validating the state of Active Directory. The Active Directory schema version (14625) is higher than the Setup’s version (14622). Therefore, PrepareSchema can’t be executed.
This is happens if you have installed Exchange 2007 SP3, which updates the schema to a later version than Exchange 2010 RTM.
You do not need to run the /PS command, only the /PrepareAD one or just run setup from the GUI.  The GUI setup will detect the schema is updated and skip that step.
Information from:
Similar blog post with issue:
Also posted as an Issue on my Issue & Tips list:
This entry was posted in Exchange, Microsoft and tagged . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s