Recently I was trying to address and issue with a corrupted arbitration mailbox. The quick fix for this issue is to delete these mailboxes and the system accounts used by them and run “setup.com /PrepareAD” to recreate them.
When I tried to run: setup /PrepareAD /IAcceptExchangeServerLicenseTerms I was getting this error:
Exchange Server 2016 requires .NET Framework 4.5 or later. Download it from http://go.microsoft.com/fwlink/?LinkId=260991.
I carried out several steps to make sure .NET was installed and working correctly. The system had 4.5.2, 4.6, 4.6.1, & 4.6.2 on it. But Exchange was running 2016 CU3 on Windows 2012 R2, which only supports 4.6.1.
FIX: For the.NET 4.5 error was to upgrade Exchange 2016 to CU4. After upgrading the servers, the SETUP command now runs fine.
.NET 4.6.1 was not supported on Exchange 2013/2016 until CU13/2, article on the lack of support initially. The June 2016 updates officially added support for 4.6.1. The September 2016 updates, CU14/3, did add support for 4.6.2, but ONLY on Windows 2016. The December 2016 updates, CU 15/4, finally add support for 4.6.2 on Windows 2012 R2.
The setup.exe for CU8 still says it needs 4.5 or later when the page below says 4.6.2 or 4.7.1
I have wasted loads of time with this, so hope it helps someone else!
I’ve have CU11 installed and it’s suddenly started doing it to me.